use strict;
my $str = '<div><x asd="asas"><![CDATA[<sender>John Smith</sender>]]></x><![CDATA[<sender>John Smith</sender>]]></div>';
my $regex = qr/<!\[CDATA\[(.*)\]\]>/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";