const regex = new RegExp('<!\\[CDATA\\[(.*)\\]\\]>', '')
const str = `<div><x asd="asas"><![CDATA[<sender>John Smith</sender>]]></x><![CDATA[<sender>John Smith</sender>]]></div>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);