#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi).+ : ""|"",\s*$"
Local $sString = " "uid" : "Text To Remain", " & @CRLF & _
" "id" : "Text2 To Stay"," & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)