const regex = new RegExp('.+ : ""|"",\\s*$', 'gmi')
const str = ` "uid" : "Text To Remain",
"id" : "Text2 To Stay",
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);