// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi).+ : ""|"",\s*$"#).unwrap();
let string = " \"uid\" : \"Text To Remain\",
\"id\" : \"Text2 To Stay\",
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}