$re = '/.+ : ""|"",\s*$/mi';
$str = ' "uid" : "Text To Remain",
"id" : "Text2 To Stay",
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;