use strict;
my $str = ' "uid" : "Text To Remain",
"id" : "Text2 To Stay",
';
my $regex = qr/.+ : ""|"",\s*$/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";