#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\w-]*)\s*:\s*(.*?)(?=\s*(?:;|$))"
Local $sString = "min-width:300px;max-width:600px;" & @CRLF & _
"overflow-wrap:break-word;" & @CRLF & _
"word-wrap" & @CRLF & _
":break-word;word-break:break-word ; margin:" & @CRLF & _
"0 auto"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")