re = /([\w-]*)\s*:\s*(.*?)(?=\s*(?:;|$))/
str = 'min-width:300px;max-width:600px;
overflow-wrap:break-word;
word-wrap
:break-word;word-break:break-word ; margin:
0 auto'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end