using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w-]*)\s*:\s*(.*?)(?=\s*(?:;|$))";
string input = @"min-width:300px;max-width:600px;
overflow-wrap:break-word;
word-wrap
:break-word;word-break:break-word ; margin:
0 auto";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}