import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w-]*)\\s*:\\s*(.*?)(?=\\s*(?:;|$))";
final String string = "min-width:300px;max-width:600px;\n"
+ "overflow-wrap:break-word;\n"
+ "word-wrap\n"
+ ":break-word;word-break:break-word ; margin:\n"
+ "0 auto";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}