const regex = /([\w-]*)\s*:\s*(.*?)(?=\s*(?:;|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w-]*)\\s*:\\s*(.*?)(?=\\s*(?:;|$))', 'g')
const str = `min-width:300px;max-width:600px;
overflow-wrap:break-word;
word-wrap
:break-word;word-break:break-word ; margin:
0 auto`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}