use strict;
my $str = 'min-width:300px;max-width:600px;
overflow-wrap:break-word;
word-wrap
:break-word;word-break:break-word ; margin:
0 auto';
my $regex = qr/([\w-]*)\s*:\s*(.*?)(?=\s*(?:;|$))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}