#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)#\w*[a-zA-Z]\w*"
Local $sString = "#1234abc" & @CRLF & _
" : Should get matched" & @CRLF & _
"#abc123" & @CRLF & _
" : Should get matched" & @CRLF & _
"#123abc123" & @CRLF & _
" : Should get matched" & @CRLF & _
"#123" & @CRLF & _
" : Should not get matched" & @CRLF & _
"#123_" & @CRLF & _
" : Should not get matched" & @CRLF & _
"#123abc_" & @CRLF & _
" : Should get matched"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")