re = /(?<!\S)#\w*[a-zA-Z]\w*/m
str = '#1234abc
: Should get matched
#abc123
: Should get matched
#123abc123
: Should get matched
#123
: Should not get matched
#123_
: Should not get matched
#123abc_
: Should get matched'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end