$re = '/(?<!\S)#\w*[a-zA-Z]\w*/m';
$str = '#1234abc
: Should get matched
#abc123
: Should get matched
#123abc123
: Should get matched
#123
: Should not get matched
#123_
: Should not get matched
#123abc_
: Should get matched';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);