import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)#\\w*[a-zA-Z]\\w*";
final String string = "#1234abc\n"
+ " : Should get matched\n"
+ "#abc123\n"
+ " : Should get matched\n"
+ "#123abc123\n"
+ " : Should get matched\n"
+ "#123\n"
+ " : Should not get matched\n"
+ "#123_\n"
+ " : Should not get matched\n"
+ "#123abc_\n"
+ " : Should get matched";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}