const regex = /(?<!\S)#\w*[a-zA-Z]\w*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)#\\w*[a-zA-Z]\\w*', 'gm')
const str = `#1234abc
: Should get matched
#abc123
: Should get matched
#123abc123
: Should get matched
#123
: Should not get matched
#123_
: Should not get matched
#123abc_
: Should get matched`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}