import re
regex = re.compile(r"(?<!\S)#\w*[a-zA-Z]\w*", flags=re.MULTILINE)
test_str = ("#1234abc\n"
" : Should get matched\n"
"#abc123\n"
" : Should get matched\n"
"#123abc123\n"
" : Should get matched\n"
"#123\n"
" : Should not get matched\n"
"#123_\n"
" : Should not get matched\n"
"#123abc_\n"
" : Should get matched")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")