import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ # Start of string\n"
+ "\\#? # Optional \"#\"\n"
+ "[a-z]{4} # Followed by 4 letters\n"
+ "\\ ? # Optional space\n"
+ "_ # Followed by an underscore\n"
+ "[ ]? # Optional space\n"
+ "[0-9]{6} # Followed by 6 digits\n"
+ "[#]? # Optional \"#\"\n"
+ "$ # End of string";
final String string = "abcd_123456\n"
+ "abcd _ 123456\n"
+ "#abcd_123456\n"
+ "abcd_123456#\n"
+ "#abcd_123456#\n"
+ "#abcd _ 123456#";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}