import re
regex = re.compile(r"""
^ # Start of string
\#? # Optional "#"
[a-z]{4} # Followed by 4 letters
\ ? # Optional space
_ # Followed by an underscore
[ ]? # Optional space
[0-9]{6} # Followed by 6 digits
[#]? # Optional "#"
$ # End of string
""", flags=re.VERBOSE | re.MULTILINE)
test_str = ("abcd_123456\n"
"abcd _ 123456\n"
"#abcd_123456\n"
"abcd_123456#\n"
"#abcd_123456#\n"
"#abcd _ 123456#")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")