re = /^ # Start of string
\#? # Optional "#"
[a-z]{4} # Followed by 4 letters
\ ? # Optional space
_ # Followed by an underscore
[ ]? # Optional space
[0-9]{6} # Followed by 6 digits
[#]? # Optional "#"
$ # End of string/xm
str = 'abcd_123456
abcd _ 123456
#abcd_123456
abcd_123456#
#abcd_123456#
#abcd _ 123456#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end