import Foundation
let pattern = ##"""
^ # Start of string
\#? # Optional "#"
[a-z]{4} # Followed by 4 letters
\ ? # Optional space
_ # Followed by an underscore
[ ]? # Optional space
[0-9]{6} # Followed by 6 digits
[#]? # Optional "#"
$ # End of string
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = ##"""
abcd_123456
abcd _ 123456
#abcd_123456
abcd_123456#
#abcd_123456#
#abcd _ 123456#
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)