import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(zn|zr|zt|zs)[a-km-zA-HJ-NP-Z1-9]{25,34}$";
final String string = "znUovxhrE91tep6D7YtgSc3XJZoYQLVDwVn\n"
+ "zszpcLB6C5B8QvfDbF2dYWXsrpac5DL9WRk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}