// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(zn|zr|zt|zs)[a-km-zA-HJ-NP-Z1-9]{25,34}$").unwrap();
let string = "znUovxhrE91tep6D7YtgSc3XJZoYQLVDwVn
zszpcLB6C5B8QvfDbF2dYWXsrpac5DL9WRk";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}