$re = '/^(zn|zr|zt|zs)[a-km-zA-HJ-NP-Z1-9]{25,34}$/m';
$str = 'znUovxhrE91tep6D7YtgSc3XJZoYQLVDwVn
zszpcLB6C5B8QvfDbF2dYWXsrpac5DL9WRk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);