re = /^(zn|zr|zt|zs)[a-km-zA-HJ-NP-Z1-9]{25,34}$/m
str = 'znUovxhrE91tep6D7YtgSc3XJZoYQLVDwVn
zszpcLB6C5B8QvfDbF2dYWXsrpac5DL9WRk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end