#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)(?s)```.*?```|`[^`]*`"
Local $sString = "some text here" & @CRLF & _
"" & @CRLF & _
"some more" & @CRLF & _
"" & @CRLF & _
"``` some code block" & @CRLF & _
"with markdown" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"some `inline code` too" & @CRLF & _
"" & @CRLF & _
"and more code blocks:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"``` xojo" & @CRLF & _
"This must have three backticks" & @CRLF & _
"flanking it" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"this text isn't matched..."
Local $sSubst = "\n----\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)