use strict;
my $str = 'some text here
some more
``` some code block
with markdown
```
some `inline code` too
and more code blocks:
``` xojo
This must have three backticks
flanking it
```
this text isn\'t matched...';
my $regex = qr/(?s)```.*?```|`[^`]*`/msp;
my $subst = '\\n----\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";