import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)```.*?```|`[^`]*`";
final String string = "some text here\n\n"
+ "some more\n\n"
+ "``` some code block\n"
+ "with markdown\n"
+ "```\n\n"
+ "some `inline code` too\n\n"
+ "and more code blocks:\n\n\n"
+ "``` xojo\n"
+ "This must have three backticks\n"
+ "flanking it\n"
+ "```\n\n"
+ "this text isn't matched...";
final String subst = "\\n----\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}