re = /(?s)```.*?```|`[^`]*`/m
str = 'some text here
some more
``` some code block
with markdown
```
some `inline code` too
and more code blocks:
``` xojo
This must have three backticks
flanking it
```
this text isn\'t matched...'
subst = '\\n----\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result