import Foundation
let pattern = #"(?s)```.*?```|`[^`]*`"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
some text here
some more
``` some code block
with markdown
```
some `inline code` too
and more code blocks:
``` xojo
This must have three backticks
flanking it
```
this text isn't matched...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n----\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)