$re = '/(?s)```.*?```|`[^`]*`/ms';
$str = 'some text here
some more
``` some code block
with markdown
```
some `inline code` too
and more code blocks:
``` xojo
This must have three backticks
flanking it
```
this text isn\'t matched...';
$subst = "\n----\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;