# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)```.*?```|`[^`]*`"
test_str = ("some text here\n\n"
"some more\n\n"
"``` some code block\n"
"with markdown\n"
"```\n\n"
"some `inline code` too\n\n"
"and more code blocks:\n\n\n"
"``` xojo\n"
"This must have three backticks\n"
"flanking it\n"
"```\n\n"
"this text isn't matched...")
subst = "\\n----\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.