using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\t+)(.+\|)(\n)((\1\t)(.+)(\n)+)+";
string substitution = @"";
string input = @" win_shell: |
Move-Item -Path ""C:\OldPath\*.dat"" -Destination ""C:\NewPath\""
info
info
info
some info
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}