const regex = /(\t+)(.+\|)(\n)((\1\t)(.+)(\n)+)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\t+)(.+\\|)(\\n)((\\1\\t)(.+)(\\n)+)+', 'gm')
const str = ` win_shell: |
Move-Item -Path "C:\\OldPath\\*.dat" -Destination "C:\\NewPath\\"
info
info
info
some info
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);