$re = '/(\t+)(.+\|)(\n)((\1\t)(.+)(\n)+)+/m';
$str = ' win_shell: |
Move-Item -Path "C:\\OldPath\\*.dat" -Destination "C:\\NewPath\\"
info
info
info
some info
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;