# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!\A)|FONT)
(?:(?!FONT).)+?\K
(?<!&)"/&quot;/gmx;t' <<< "lorem ipsum lorem ipsum <FONT COLOR=\"#FF0000\">&lt;csf style="Italic CH" &"italic="on"&gt;</FONT> lorem ipsum
some " here and here " as well"