import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A)|FONT)\n"
+ "(?:(?!FONT).)+?\\K\n"
+ "(?<!&)"";
final String string = "lorem ipsum lorem ipsum <FONT COLOR=\"#FF0000\">&lt;csf style="Italic CH" &"italic="on"&gt;</FONT> lorem ipsum\n"
+ "some " here and here " as well";
final String subst = "&quot;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}