#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mx)(?:\G(?!\A)|FONT)" & @CRLF & _
"(?:(?!FONT).)+?\K" & @CRLF & _
"(?<!&)""
Local $sString = "lorem ipsum lorem ipsum <FONT COLOR="#FF0000">&lt;csf style="Italic CH" &"italic="on"&gt;</FONT> lorem ipsum" & @CRLF & _
"some " here and here " as well"
Local $sSubst = "&quot;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)