import Foundation
let pattern = #"""
(?:\G(?!\A)|FONT)
(?:(?!FONT).)+?\K
(?<!&)"
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = ##"""
lorem ipsum lorem ipsum <FONT COLOR="#FF0000">&lt;csf style="Italic CH" &"italic="on"&gt;</FONT> lorem ipsum
some " here and here " as well
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"&quot;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)