$re = '~(?:\G(?!\A)|FONT)
(?:(?!FONT).)+?\K
(?<!&)"~mx';
$str = 'lorem ipsum lorem ipsum <FONT COLOR="#FF0000">&lt;csf style="Italic CH" &"italic="on"&gt;</FONT> lorem ipsum
some " here and here " as well';
$subst = "&quot;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;