using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|FONT)
(?:(?!FONT).)+?\K
(?<!&)"";
string substitution = @"&quot;";
string input = @"lorem ipsum lorem ipsum <FONT COLOR=""#FF0000"">&lt;csf style="Italic CH" &"italic="on"&gt;</FONT> lorem ipsum
some " here and here " as well";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}