#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bF[A-Z]{0,2}\b"
Local $sString = "F" & @CRLF & _
"FA" & @CRLF & _
"FB" & @CRLF & _
"FAA" & @CRLF & _
"FAAA"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)