using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bF[A-Z]{0,2}\b";
string substitution = @"";
string input = @"F
FA
FB
FAA
FAAA";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}