use strict;
my $str = 'F
FA
FB
FAA
FAAA';
my $regex = qr/\bF[A-Z]{0,2}\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";