const regex = /\bF[A-Z]{0,2}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bF[A-Z]{0,2}\\b', 'gm')
const str = `F
FA
FB
FAA
FAAA`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);