#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z](?!.*(['-]).*\1)(?!.* )(?=.{0,19}$)[a-zA-Z'-]*(?: (?<=[a-zA-Z] )[a-zA-Z][a-zA-Z'-]*)*$"
Local $sString = "This is aa" & @CRLF & _
"This is aa test" & @CRLF & _
"aa aa aa aa aa aa aa" & @CRLF & _
"This should m'atch" & @CRLF & _
"This a-lso'" & @CRLF & _
"This is a test" & @CRLF & _
"a b" & @CRLF & _
"aa" & @CRLF & _
"a" & @CRLF & _
"" & @CRLF & _
"This is 4 test" & @CRLF & _
"This is aa test" & @CRLF & _
"This' is aa tes" & @CRLF & _
"" & @CRLF & _
"This is aaaa longer test" & @CRLF & _
"This sh'o'uld not" & @CRLF & _
"This sh-o-uld not" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")