const regex = /^[a-zA-Z](?!.*(['-]).*\1)(?!.* )(?=.{0,19}$)[a-zA-Z'-]*(?: (?<=[a-zA-Z] )[a-zA-Z][a-zA-Z'-]*)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z](?!.*([\'-]).*\\1)(?!.* )(?=.{0,19}$)[a-zA-Z\'-]*(?: (?<=[a-zA-Z] )[a-zA-Z][a-zA-Z\'-]*)*$', 'gm')
const str = `This is aa
This is aa test
aa aa aa aa aa aa aa
This should m'atch
This a-lso'
This is a test
a b
aa
a
This is 4 test
This is aa test
This' is aa tes
This is aaaa longer test
This sh'o'uld not
This sh-o-uld not
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}