# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z](?!.*(['-]).*\1)(?!.* )(?=.{0,19}$)[a-zA-Z'-]*(?: (?<=[a-zA-Z] )[a-zA-Z][a-zA-Z'-]*)*$"
test_str = ("This is aa\n"
"This is aa test\n"
"aa aa aa aa aa aa aa\n"
"This should m'atch\n"
"This a-lso'\n"
"This is a test\n"
"a b\n"
"aa\n"
"a\n\n"
"This is 4 test\n"
"This is aa test\n"
"This' is aa tes\n\n"
"This is aaaa longer test\n"
"This sh'o'uld not\n"
"This sh-o-uld not\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.